Skip to main content

VRF-Lite

Diagram

Classes

overlay_extensions (vxlan)

NameTypeConstraintMandatoryDefault Value
vrf_litesList[vrf_lites]No

vrf_lites (vxlan.overlay_extensions)

NameTypeConstraintMandatoryDefault Value
nameStringYes
vrfStringYes
ospfClass[ospf]No
bgpClass[bgp]No
redistributionList[redistribution]No
switchesList[switches]No

ospf (vxlan.overlay_extensions.vrf_lites)

NameTypeConstraintMandatoryDefault Value
processStringRegex: ^[A-Za-z0-9-_]{1,20}$Yes
default_areaAnyInteger[min: 0, max: 4294967295] or IPNo0
areasList[areas]No
distanceIntegermin: 1, max: 255No110
bfdClass[bfd]No

bgp (vxlan.overlay_extensions.vrf_lites)

NameTypeConstraintMandatoryDefault Value
best_path_as_path_relaxBooleantrue, falseNofalse
graceful_restartBooleantrue, falseNotrue
graceful_restart_helperBooleantrue, falseNofalse
local_asIntegermin: 1, max: 4294967295No
address_family_ipv4_unicastClass[address_family_ipv4_unicast]No
address_family_ipv6_unicastClass[address_family_ipv6_unicast]No

redistribution (vxlan.overlay_extensions.vrf_lites)

NameTypeConstraintMandatoryDefault Value
sourceChoicebgp, ospf, static, directNo
protocol_tagStringNo
route_map_ipv4StringNo
route_map_ipv6StringNo

switches (vxlan.overlay_extensions.vrf_lites)

NameTypeConstraintMandatoryDefault Value
nameStringYes
router_idIPNo
loopback_idIntegermin: 0, max: 1023No
static_routesClass[static_routes]No
interfacesList[interfaces]No
bgpClass[bgp]No
ospfClass[ospf]No
bgp_peersList[bgp_peers]No
redistributionList[redistribution]No

areas (vxlan.overlay_extensions.vrf_lites.ospf)

NameTypeConstraintMandatoryDefault Value
idAnyInteger[min: 0, max: 4294967295] or IPNo
area_typeChoicestandard, stub, nssa, totally_stubNostandard
area_costIntegermin: 1, max: 16777215No
nssaClass[nssa]No
default_information_originateClass[default_information_originate]No

bfd (vxlan.overlay_extensions.vrf_lites.ospf)

NameTypeConstraintMandatoryDefault Value
enabledBooleantrue, falseNofalse

address_family_ipv4_unicast (vxlan.overlay_extensions.vrf_lites.bgp)

NameTypeConstraintMandatoryDefault Value
additional_paths_sendBooleantrue, falseNofalse
additional_paths_receiveBooleantrue, falseNofalse
additional_paths_selection_route_mapStringNo
default_originateBooleantrue, falseNofalse
ebgp_distanceIntegermin: 1, max: 255No20
ibgp_distanceIntegermin: 1, max: 255No200
local_distanceIntegermin: 1, max: 255No220

static_routes (vxlan.overlay_extensions.vrf_lites.switches)

NameTypeConstraintMandatoryDefault Value
static_ipv4List[static_ipv4]No
static_ipv6List[static_ipv6]No

interfaces (vxlan.overlay_extensions.vrf_lites.switches)

NameTypeConstraintMandatoryDefault Value
nameAnyString[Regex: (?i)^(?:e|eth(?:ernet)?)\d(?:\/\d+){1,2}$] or String[Regex: (?i)^(po|port-channel)([1-9]|[1-9][0-9]{1,2}|[1-3][0-9]{3}|40[0-8][0-9]|409[0-6])$] or String[Regex: (?i)^(?:e|eth(?:ernet)?)\d(?:\/\d+){1,2}\.\d{1,4}$] or String[Regex: (?i)^(?:po|port-channel:?)((?:[1-9]|[1-9]\d{1,2}|[1-3]\d{3}|40[0-8]\d|409[0-6]:?)\.(?:[1-9]|[1-9]\d{1,2}|[1-3]\d{3}|40[0-8]\d|409[0-3]:?))$] or String[Regex: (?i)^(lo|loopback)([0-9]|[1-9][0-9]{1,2}|10[0-1][0-9]|102[0-3])$]Yes
ospfClass[ospf]No

bgp_peers (vxlan.overlay_extensions.vrf_lites.switches)

NameTypeConstraintMandatoryDefault Value
addressIPYes
remote_asIntegermin: 1, max: 4294967295No
local_asIntegermin: 1, max: 4294967295No
update_sourceStringNo
descriptionStringNo
passwordStringNo
bfdClass[bfd]No
disable_connected_checkBooleantrue, falseNofalse
remove_private_asBooleantrue, falseNofalse
remove_private_as_allBooleantrue, falseNofalse
ebgp_multihopIntegermin: 2, max: 255No2
address_family_ipv4_unicastClass[address_family_ipv4_unicast]No
address_family_ipv6_unicastClass[address_family_ipv6_unicast]No

nssa (vxlan.overlay_extensions.vrf_lites.ospf.areas)

NameTypeConstraintMandatoryDefault Value
default_information_originateBooleantrue, falseNo
route_mapStringNo
no_redistributionBooleantrue, falseNo
no_summaryBooleantrue, falseNo
translateClass[translate]No

default_information_originate (vxlan.overlay_extensions.vrf_lites.ospf.areas)

NameTypeConstraintMandatoryDefault Value
alwaysBooleantrue, falseNo
route_mapStringNo

static_ipv4 (vxlan.overlay_extensions.vrf_lites.switches.static_routes)

NameTypeConstraintMandatoryDefault Value
prefixIPNo
route_tagIntegermin: 0, max: 4294967295No
next_hopsList[next_hops]No

static_ipv6 (vxlan.overlay_extensions.vrf_lites.switches.static_routes)

NameTypeConstraintMandatoryDefault Value
prefixIPNo
route_tagIntegermin: 0, max: 4294967295No
next_hopsList[next_hops]No

ospf (vxlan.overlay_extensions.vrf_lites.switches.interfaces)

NameTypeConstraintMandatoryDefault Value
areaAnyInteger[min: 0, max: 4294967295] or IPNo
auth_typeChoicenone, simple, md5Nonone
auth_key_idIntegermin: 0, max: 255No0
auth_keyStringNo
costIntegermin: 1, max: 65535No1
passive_interfaceBooleantrue, falseNofalse
mtu_ignoreBooleantrue, falseNofalse
advertise_subnetBooleantrue, falseNofalse
bfdClass[bfd]No
hello_intervalIntegermin: 1, max: 65535No10
dead_intervalIntegermin: 1, max: 65535No40
network_typeChoicepoint-to-point, broadcastNobroadcast
priorityIntegermin: 0, max: 255No1
lsa_retransmit_intervalIntegermin: 1, max: 65535No5
lsa_transmit_delayIntegermin: 1, max: 65535No1

address_family_ipv4_unicast (vxlan.overlay_extensions.vrf_lites.switches.bgp_peers)

NameTypeConstraintMandatoryDefault Value
send_communityBooleantrue, falseNofalse
send_ext_communityBooleantrue, falseNofalse
allow_as_inBooleantrue, falseNofalse
allow_as_in_numberIntegermin: 1, max: 10No3
as_overrideBooleantrue, falseNofalse
default_originateBooleantrue, falseNofalse
next_hop_selfBooleantrue, falseNofalse
route_reflector_clientBooleantrue, falseNofalse
weightIntegermin: 0, max: 65535No
route_map_inStringNo
route_map_outStringNo

translate (vxlan.overlay_extensions.vrf_lites.ospf.areas.nssa)

NameTypeConstraintMandatoryDefault Value
alwaysBooleantrue, falseNo
neverBooleantrue, falseNo
supress_faBooleantrue, falseNo

next_hops (vxlan.overlay_extensions.vrf_lites.switches.static_routes.static_ipv4)

NameTypeConstraintMandatoryDefault Value
ipIPNo
nameStringNo
trackIntegermin: 1, max: 512No
route_preferenceIntegermin: 1, max: 255No

next_hops (vxlan.overlay_extensions.vrf_lites.switches.static_routes.static_ipv6)

NameTypeConstraintMandatoryDefault Value
ipIPNo
nameStringNo
trackIntegermin: 1, max: 512No
route_preferenceIntegermin: 1, max: 255No

Example 1 - VRF-Lite Static routes

This CLI configuration defines routing settings within a specific Virtual Routing and Forwarding (VRF) instance named Nac-VRF21. Here's a breakdown of the commands:

  1. vrf context Nac-VRF21: This command specifies the beginning of configuration for the VRF named Nac-VRF21. VRFs are used to create separate routing tables on the same router, allowing for network segmentation and isolation.

  2. ip route 10.1.1.0/24 192.168.10.1 tag 12345: This command adds a static route for the IPv4 subnet 10.1.1.0/24 with the next-hop IP address 192.168.10.1. The route is marked with a tag of 12345, which can be used for route policies or identification purposes.

  3. ip route 10.1.1.0/24 192.168.20.1 tag 12345: This is another static route for the same IPv4 subnet 10.1.1.0/24, but with a different next-hop IP address, 192.168.20.1. It shares the same tag, 12345, as the previous route.

  4. ip route 10.1.2.0/24 192.168.10.1 tag 12345: This command adds a static route for the IPv4 subnet 10.1.2.0/24 with the next-hop address 192.168.10.1, also tagged with 12345.

  5. ip route 10.1.2.0/24 192.168.20.1 track 10 name rtr2 tag 12345: This static route is for the same subnet 10.1.2.0/24, but uses the next-hop address 192.168.20.1. It is associated with a tracking object (track 10) named rtr2. Tracking allows the route to be conditionally installed based on the state of the tracked object, which could be an interface status or reachability check. The route is tagged with 12345.

  6. ipv6 route 2a00:db8::/32 2a01::1: This command adds a static route for the IPv6 network 2a00:db8::/32 with the next-hop IPv6 address 2a01::1. Unlike the IPv4 routes, this one does not include a tag.

Overall, this configuration sets up multiple static routes within the Nac-VRF21 context, allowing for both IPv4 and IPv6 routing, with some routes being tracked for specific conditions.

VRF-lite static route example in CLI
vrf context Nac-VRF21
ip route 10.1.1.0/24 192.168.10.1 tag 12345
ip route 10.1.1.0/24 192.168.20.1 tag 12345
ip route 10.1.2.0/24 192.168.10.1 tag 12345
ip route 10.1.2.0/24 192.168.20.1 track 10 name rtr2 tag 12345
ipv6 route 2a00:db8::/32 2a01::1
vrf-lite.nac.yaml
---
vxlan:
overlay_extensions:
vrf_lites:
- name: Static-NaC-VRF21_vrf_lite
vrf: NaC-VRF21
switches:
- name: netascode-bleaf21
static_routes:
static_ipv4:
- prefix: 10.1.1.0/24
route_tag: 12345
next_hops:
- ip: 192.168.20.1
- ip: 192.168.10.1
- prefix: 10.1.2.0/24
route_tag: 12345
next_hops:
- ip: 192.168.10.1
- ip: 192.168.20.1
track: 10
name: rtr2
static_ipv6:
- prefix: 2a00:db8::/32
next_hops:
- ip: 2a01::1

Example 2 - VRF-Lite OSPF

This configuration sets up routing features for a specific VRF (Virtual Routing and Forwarding) and interface. Here's a detailed explanation:

  1. feature ospf: This command enables the OSPF (Open Shortest Path First) routing protocol feature on the device.

  2. feature bfd: This command enables the BFD (Bidirectional Forwarding Detection) feature, which is used to provide rapid detection of faults in the bidirectional path between two forwarding engines, enhancing the reliability of the network.

  3. router ospf OVERLAY: This block configures an OSPF process named "OVERLAY."

    • vrf NaC-VRF21: This specifies that the OSPF process "OVERLAY" is associated with the VRF named NaC-VRF21.
    • router-id 1.1.2.21: This sets the OSPF router ID to 1.1.2.21, which is used to uniquely identify the router in the OSPF domain.
    • redistribute bgp 65000.2 route-map rm-redistribute-ospf: This command redistributes routes from BGP (Autonomous System 65000.2) into the OSPF process using a route-map named rm-redistribute-ospf. This allows for control over which BGP routes are injected into OSPF.
  4. router bgp 65000.2: This block configures BGP for Autonomous System 65000.2.

    • vrf NaC-VRF21: This specifies that the BGP process is associated with the VRF NaC-VRF21.
    • address-family ipv4 unicast: This command specifies the IPv4 unicast address family for BGP, indicating that it will handle IPv4 unicast routing.
    • redistribute ospf OVERLAY route-map rm-default_only: This command redistributes routes from the OSPF process "OVERLAY" into BGP using a route-map named rm-default_only. This controls which OSPF routes are injected into BGP.
  5. interface ethernet1/2.10: This block configures the subinterface ethernet1/2.10.

    • ip ospf network point-to-point: This specifies that the OSPF network type for this interface is point-to-point, which is typically used for direct links between two routers.
    • ip router ospf OVERLAY area 0.0.0.0: This assigns the interface to OSPF area 0.0.0.0 for the OVERLAY OSPF process.
    • ip ospf authentication message-digest: This enables OSPF message-digest authentication on the interface, providing a higher level of security by ensuring that OSPF packets are authenticated.
    • ip ospf message-digest-key 0 md5 3 a667d47acc18ea6b8da14f191e5f53b5: This sets up an MD5 authentication key (key number 0) with the key value a667d47acc18ea6b8da14f191e5f53b5 for OSPF message-digest authentication. 3 configures the pass key as 3DES encrypted.
    • ip ospf bfd: This enables BFD for OSPF on the interface, allowing for fast failure detection.
    • ip ospf dead-interval 40: This sets the OSPF dead interval to 40 seconds, which is the time the router will wait to declare a neighbor down if no OSPF hello packets are received.

Overall, this configuration sets up OSPF and BGP routing with specific redistribution policies, authentication, and fast failure detection for a VRF and an interface on the network device.

vrf-lite with ospf example in CLI
feature ospf
feature bfd
!
!
router ospf OVERLAY
vrf NaC-VRF21
router-id 1.1.2.21
redistribute bgp 65000.2 route-map rm-redistribute-ospf
!
router bgp 65000.2
vrf NaC-VRF21
address-family ipv4 unicast
redistribute ospf OVERLAY route-map rm-default_only
!
interface ethernet1/2.10
ip ospf network point-to-point
ip router ospf OVERLAY area 0.0.0.0
ip ospf authentication message-digest
ip ospf message-digest-key 0 md5 3 a667d47acc18ea6b8da14f191e5f53b5
ip ospf bfd
ip ospf dead-interval 40
tip

auth_key should be given in 3DES.

vrf-lite.nac.yaml
---
vxlan:
overlay_extensions:
vrf_lites:
- name: OSPF-NaC-VRF21_vrf_lite
vrf: NaC-VRF21
ospf:
process: OVERLAY
areas:
- id: 0
area_type: standard
bfd:
enabled: true
switches:
- name: netascode-bleaf21
router_id: 1.1.2.21
redistribution:
- source: bgp
route_map_ipv4: rm-redistribute-ospf
- source: ospf
route_map_ipv4: rm-default_only
interfaces:
- name: ethernet1/2.10
ospf:
area: 0.0.0.0
passive_interface: false
network_type: point-to-point
auth_key: a667d47acc18ea6b8da14f191e5f53b5 # should be 3des
auth_type : md5
bfd:
enabled: true

Example 3 - VRF-Lite BGP

This example will create BGP session. On switch border1 we have configure an ebgp session to 10.1.1.1 with the remote as 65010. We overide the as number with the local as 1234. BGP updates are source with interface Loopback101.

On switch dc-border2, we have a bgp session with a range 192.168.1.0/24 on AS number: 65010.

vrf-lite.nac.yaml
      - name: bgp_vrf_red_vrf_lite
vrf: vrf_red
bgp:
redistribution:
- source: bgp
route_map: fabric-rmp-redist-bgp
- source: ospf
route_map: fabric-rmp-redist-ospf
- source: direct
route_map: fabric-rmp-redist-direct
- source: static
route_map: fabric-rmp-redist-static
switches:
- name: dc-border1
router_id: 1.1.1.1
loopback_id: 101
bgp_peers:
- address: 10.1.1.1
remote_as: 65010
local_as: 1234
description: BGP Peer 1
update_source: Loopback101
bfd:
enabled: true
disable_connected_check: true
remove_private_as: true
remove_private_as_all: true
password: 014903c077689077e5b4548432c3d91d # 3DES encrypted password
- name: dc-border2
router_id: 2.2.2.2
loopback_id: 101
bgp:
best_path_as_path_relax: true
local_as: 1102
address_family_ipv4_unicast:
additional_paths_receive: true
additional_paths_send: true
additional_paths_selection_route_map: addtionalpath_route_map
redistribution:
- source: direct
route_map: fabric-rmp-redist-direct
- source: static
route_map: fabric-rmp-redist-static
bgp_peers:
- address: 192.168.1.0/24
remote_as: 65010
description: k8s nodes
ebgp_multihop: 5
address_family_ipv4_unicast:
route_map_out: route-map-k8s-node-out
weight: 100
- address: 2002::1
remote_as: 4876387
address_family_ipv4_unicast:
send_community: true
send_ext_community: true
as_override: true
next_hop_self: true
default_originate: true
route_map_in: route-map-isp-ipv4-in
route_map_out: route-map-isp-ipv4-out
address_family_ipv6_unicast:
send_community: true
send_ext_community: true
route_map_in: route-map-isp-ipv6-in
route_map_out: route-map-isp-ipv6-out